Thirdfort

Disruption to Service
Resolved·Partial outage

This outage now appears to be resolved.

Mon, Oct 20, 2025, 10:52 AM
(1 week ago)
·
Affected components
Client Portal
Support
Updates

Resolved

This outage now appears to be resolved.

Mon, Oct 20, 2025, 10:52 AM

Monitoring

Service Update

One of our external providers experienced an outage, which affected our client portal across both Thirdfort and Homeppl. Our phone line was also impacted during this time.

We are monitoring the situation and can confirm it was related to the wider outage affecting a number of other online services, as reported by the BBC.

This outage now appears to be resolved, and we are monitoring the situation going forward.

Mon, Oct 20, 2025, 09:46 AM(1 hour earlier)

Identified

Service Update

One of our external providers is currently experiencing an outage, which is affecting our client portal across both Thirdfort and Homeppl. You may still be able to access the platform, but some actions—such as 2FA resets—may not be available at this time.

Our phone line is also impacted. If you need to reach our team, please use live chat for the fastest response.

We are monitoring the situation and can confirm it is related to the wider outage affecting a number of other online services, as reported by the BBC.

Mon, Oct 20, 2025, 08:58 AM(47 minutes earlier)

Identified

Service Update One of our external providers is currently experiencing an outage, which is affecting our client portal across both Thirdfort and Homeppl. You may still be able to access the platform, but some actions—such as 2FA resets—may not be available at this time. Our phone line is also impacted. If you need to reach our team, please use live chat for the fastest response. We are monitoring the situation closely and will provide updates as soon as they become available.

Mon, Oct 20, 2025, 08:43 AM(14 minutes earlier)