Earlier this week, on 29 September at 12.30pm, we found two ongoing issues. Those issues were:
NFC and banking tasks – Some consumers are experiencing errors completing NFC and banking tasks in the mobile app (both Android and iOS).
Delays in check completion – Some checks that include screening are delayed in their processing which means they are not completing in the usual time frame we would expect, however we are ultimately seeing that these checks are completing successfully.
We implemented fixes shortly afterward and we’ve been monitoring closely since this time to ensure everything is working as expected.
We’re happy to confirm that the platform is now operating normally, the vast majority of affected checks have now been processed and we have been in touch individually regarding a small number of checks that were unrecoverable. We consider this incident resolved.
Thank you for your patience and understanding as we resolved this issue.
Resolved
Earlier this week, on 29 September at 12.30pm, we found two ongoing issues. Those issues were:
NFC and banking tasks – Some consumers are experiencing errors completing NFC and banking tasks in the mobile app (both Android and iOS).
Delays in check completion – Some checks that include screening are delayed in their processing which means they are not completing in the usual time frame we would expect, however we are ultimately seeing that these checks are completing successfully.
We implemented fixes shortly afterward and we’ve been monitoring closely since this time to ensure everything is working as expected.
We’re happy to confirm that the platform is now operating normally, the vast majority of affected checks have now been processed and we have been in touch individually regarding a small number of checks that were unrecoverable. We consider this incident resolved.
Thank you for your patience and understanding as we resolved this issue.
Investigating
We are currently investigating two issues affecting our platform:
NFC and banking tasks – Some consumers are experiencing errors completing NFC and banking tasks in the mobile app (both Android and iOS).
Delays in check completion – Some checks that include screening are delayed in their processing which means they are not completing in the usual time frame we would expect, however we are ultimately seeing that these checks are completing successfully.
We're actively investigating the root causes and working to restore normal functionality. We’ll provide updates as soon as more information is available.
Thank you for your patience while we work to resolve these issues.